Κυριακή, 25 Μαΐου 2014

Word cloud με tagxedo.com

Είναι διασκεδαστικό να χρησιμοποιείς το tagxedo.com και να φτιάχνεις word-clouds.
Σας θυμίζει τo wordle.net, αλλά είναι πληρέστερο!

Σαφείς οδηγίες θα βρείτε στο
http://techietuesday.wikispaces.com/file/view/Tagxedo,+How+to.pdf
Δοκιμάστε το και θα εκπλαγείτε!

Δευτέρα, 5 Μαΐου 2014

4 ΕΡΩΤΗΜΑΤΑ

ΘΕΜΑ 1 (Προγραμματισμός)
1.       Να αντιστοιχίσετε κάθε στοιχείο της πρώτης στήλης με κάποιο από αυτά της δεύτερης.
Ύψος<-- 1.76

Εντολή επανάληψης
ΔΙΑΒΑΣΕ βαθμός

Συνθήκη
ΓΡΑΨΕ ‘Ο βαθμός στα μαθηματικά είναι’, βαθμός

Τμήμα δήλωσης μεταβλητών
ΟΣΟ x<10 ΕΠΑΝΑΛΑΒΕ

Εντολή Επιλογής
Απουσίες > 50
Εντολή εισόδου
ΑΝ x<10 ΤΟΤΕ

Εντολή εκχώρησης
ΑΚΕΡΑΙΕΣ: πόντοι, αρ_παίχτη

Εντολή εξόδου

2.       α. Ποιοι είναι οι 4 τύποι μεταβλητών που υποστηρίζει η γλώσσα;
β. Σε ποιον τύπο θα κατατάσσατε τις μεταβλητές:
               
·         Αριθμός_απουσιών
·         Μέσος_Ορος_Τετραμήνου
·         Ονομα_μαθητή
·         Παίρνει_Αριστείο

ΘΕΜΑ 2 (Υλικό του υπολογιστή)
1.       Το υλικό ενός υπολογιστή διακρίνεται σε 2 μέρη. Ποια είναι αυτά; Σε ποιο μέρος ανήκει κάθε μία από τις ακόλουθες συσκευές:  

Κεντρική Μονάδα Επεξεργασίας (Επεξεργαστής), Πληκτρολόγιο, Οθόνη, Εκτυπωτής, Κύρια μνήμη (RAM & ROM)

2.       Να σχεδιάσετε και να αναφέρετε τις ονομασίες των τριών κυριότερων τρόπων διασύνδεσης των υπολογιστών (τοπολογία δικτύων).

ΘΕΜΑ 3 (Παρουσιάσεις)
Να δημιουργήσετε αρχείο παρουσίασης με θέμα το ΚΑΛΟΚΑΙΡΙ, που θα αποτελείται από 5 διαφάνειες και στο οποίο θα χρησιμοποιήσετε τις ακόλουθες τεχνικές:
·         Εναλλαγή διαφανειών με κίνηση & ήχο που συνεχίζει να παίζει και στις επόμενες διαφάνειες
·         Εμφάνιση & απόσυρση αντικειμένων (πχ. Φωτογραφίας, λεζάντα) με κίνηση
·         Αλλαγή χρώματος ή εφέ φόντου στις διαφάνειες
·         Εισαγωγή υπερσυνδέσμου σε ιστοσελίδα
·         Ενσωμάτωση βίντεο
·         Μέγεθος γραμματοσειράς τίτλου 30
·         Μέγεθος γραμματοσειράς κειμένου 18
·         Χρήση υποσέλιδου με μέγεθος γραμματοσειράς κειμένου 10 και έντονη γραφή


ΘΕΜΑ 4 (Διαδίκτυο – Ιστοσελίδες)
Να δημιουργήσετε 2 αρχεία-ιστοσελίδες στον επεξεργαστή κειμένου (MS Word ή LibreOffice Write),  με θέμα το Leonardo Da Vinci και  την Τζοκόντα.  Κάθε ιστοσελίδα θα πρέπει
·         Να περιλαμβάνει τουλάχιστον 3 περιεκτικές προτάσεις για το θέμα
(πχ. Τι ήταν Leonardo da Vinci, πότε και που γεννήθηκε, ποια ήταν τα σημαντικότερα έργα του)
·         Να περιέχει έναν υπερσύνδεσμο που θα παραπέμπει στην άλλη ιστοσελίδα

(Leonardo Da Vinci <-> Gioconda)

ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΣ

1. Συμπληρώστε τα κενά (…..) προκειμένου τα παρακάτω τμήματα προγράμματος σε ΓΛΩΣΣΑ της στήλης Α να επιλύουν το πρόβλημα της στήλης Β

ΣΤΗΛΗ Α.
ΣΤΗΛΗ Β.
ΔΙΑΒΑΣΕ Α
ΑΝ Α …….  ........ = 0 ΤΟΤΕ
ΓΡΑΨΕ ‘Ο’, Α, ‘ΕΊΝΑΙ …..’
……
……. ‘Ο’, Α, ‘ΕΙΝΑΙ ….’
………

ΕΛΕΓΧΟΣ ΑΝ ΕΝΑΣ ΑΡΙΘΜΟΣ Α ΕΙΝΑΙ ΜΟΝΟΣ ή ΖΥΓΟΣ ΚΑΙ ΕΜΦΑΝΙΣΗ ΤΟΥ ΑΠΟΤΕΛΕΣΜΑΤΟΣ
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
         ΔΙΑΒΑΣΕ Ν
…..  Ν….. 5
Σ …….    ……..
ΓΙΑ …… ΑΠΟ ….. ΜΕΧΡΙ  Ν ΜΕ_ΒΗΜΑ …..
Σ  <-- …….  ……..  ………
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ‘……………..’, …..

Να γραφεί πρόγραμμα που να διαβάζει θετικό ακέραιο αριθμό Ν>5 και να υπολογίζει το άθροισμα των περιττών μεταξύ 1 και Ν.

2. Προσδιορίστε τον τύπο και το όνομα στις παρακάτω μεταβλητές:
ΜΕΤΑΒΛΗΤΗ
ΟΝΟΜΑ
ΤΥΠΟΣ
ΑΡΙΘΜΟΣ ΠΑΙΔΙΩΝ


ΜΙΣΘΟΣ


ΟΝΟΜΑ ΜΑΘΗΤΗ


ΥΠΟΛΟΙΠΟ ΑΚΕΡΑΙΑΣ ΔΙΑΙΡΕΣΗΣ



3. Ποιο πρόβλημα επιλύει ο καθένας από τους παρακάτω αλγόριθμους:
ΑΛΓΟΡΙΘΜΟΣ
ΠΡΟΒΛΗΜΑ
<--0
<--0
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
ΔΙΑΒΑΣΕ Α
ΑΝ Α>=0 ΤΟΤΕ
<--P+1
ΑΛΛΙΩΣ
<--N+1
ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ Ρ
ΓΡΑΨΕ Ν

Κ <-- 3.14
ΔΙΑΒΑΣΕ Ρ
Ε <-- Κ*Ρ*Ρ
Π <--2*Κ*Ρ
ΓΡΑΨΕ Ε
ΓΡΑΨΕ Κ
ΓΡΑΨΕ Π



4. Να περιγράψετε τον παρακάτω αλγόριθμο με διάγραμμα ροής
....
ΔΙΑΒΑΣΕ Χ
FOUND<--0
Ι<--1
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ‘Προσπάθεια:’, Ι
ΔΙΑΒΑΣΕ Α
ΑΝ Α=Χ ΤΟΤΕ
ΓΡΑΨΕ ‘ΜΠΡΑΒΟ ΤΟ ΒΡΗΚΕΣ’
FOUND<--1
ΑΛΛΙΩΣ
ΑΝ Α>Χ ΤΟΤΕ
ΓΡΑΨΕ ‘Ο αριθμός που έδωσες είναι ΜΕΓΑΛΥΤΕΡΟΣ’
ΑΛΛΙΩΣ
ΓΡΑΨΕ ‘Ο αριθμός που έδωσες είναι ΜΙΚΡΟΤΕΡΟΣ’
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΑΝ
ΜΕΧΡΙΣ_ΟΤΟΥ FOUND=1
....